Reasons Why Your Game Won't Show Up In Discovery

We get a lot of post on the forum asking why their game won’t show up in Discovery. Well there are a few reasons why that may be. So I made this much needed guide with the help of others to help inform you on a few reasons why you can’t find your game.

Publishing Reasons

  1. Have numbers in the description
  2. Has Cuss Words
  3. Have the words “Join” and “Code”
  4. Not searching part of the Description
  5. Has live code in the game or game description
  6. Has a copyrighted Thumbnail or name
  7. Doesn’t follow the Community Rules for Publishing with Gimkit Creative

In-game Reasons

  1. Representation of gore or violent content
  2. Includes mature content, or content that wouldn’t be acceptable to be viewed in a classroom setting.
  3. Violence

Possible Fixes
1.Depublish and Republish the game after removing that stuff.

If your game is still not there check here to see if it violates any of the rules and if you still can’t find it email the people on here can’t do anything, we aren’t the mods.




Wait, really? How did @M13TheCreator find this out?

lets just say I do my research :wink:

ask me again if u want the full explanation


@111 don’t edit if its not a valid reason.

wait who deleted my answers?

It is for a valid reason, im trying to give intel

wdym numbers in desc?

this wiki kinda seems empty

if there as 3 or more numbers in 1 word it wont work!


he said not to tho. so dont.

ok im looking at all the countless post about it and finding reasons, thats why its not finished.


can i ask again :eyes:

sigh please don’t ruin this guide…

1 Like

what happened to 4 and 5?

its a wiki, its a make n progress, wolftech and some other people are researching the answers, and will come eventually…


Gotcha. Was a bit confused. Thank you!

1 Like

alright, sorry :frowning:

If it has only code or only j0in is it ok? Or is it an and/or situation?

me and my brother published games he did 2 I did 1 and none of them worked!
so I looked at others and at ours and sat for like 2 hours thinking why it didn’t worked then I found that out!