|WARNING⚠️| [ ] + 1 for changing properties wont work

So you see how some guides show code with

Set Property: "insert property here"
Value to: [ ] + 1 ?

Well… I was helping @top-z because his selling system didn’t work. and we couldn’t find what went wrong. I say “sir I cant find where the properties are being changed”. He said it was in the trigger so I look. and see

Set Property: "not leaking it"
                            Value to: [ ] + 1 .

What that’s doing is making the property nothing(0) + 1. when I made it

Set Property: "still not leaking"
Value to: [ get property: "still not leaking" ] + 1

, it worked.

If I’m wrong, correct me. But this didn’t work for Top Z and might’ve been a bug that was quietly fixed on August 30th.

okay still working on 2 guides. uhm ceeya

reason for psa

was told to. if is wrong just tell me and I fix.


This is a bit weirdly formatted. Also, my voting system uses this a lot, and that works. I might be misunderstanding it though.

it undid my formating but what im trying to say it didn’t work

Wait, so what does +1 mean? Does that just set the property to one?

No. He means that adding one to it doesn’t work.

@Cryptoraider_Gemkit, can you show some screenshots?

value + 1 works when the property is a number value, when its a text value, it concatenates it


Screenshot 2023-10-20 191549
this is bare bones information. and is just the point. top didn’t work and bottom did. @ClicClac + 1 is the top
@getrithekd here is the screenshot of the sample i made
and @kyro the properties are numbers (just for context)

sorry for late response i was eating dinner

i dont get it, top one obviously isn’t gonna work because you’re not adding something to the actual property (or to anything at all)


the top one is what + 1 is. this is what I’m trying to say wont work. I’ve seen some guides using it such as How to make a simple fishing system AND Loot Tables [SIMPLIFIED, UPDATED, AND WITH PICTURES] 4/10 - #29 by FireAlta2183 (no hate to blizzy)


blizzys guide used a variable and gave players the amount that the variable states, so it doesn’t really

Is this a bug guide, or a community made guide?

it changes the property the variable is for the loottable

1 Like

its kind of a psa but more for creating maps

Hmm Ok! You could say what the square means, like a key or something! it is kind of confusing, maybe use formatting?

1 Like

yeah, couldve worded this better /nm


Perhaps add PSA to it?

the square is used because of me using scartchblocks on the scratch forum and is just what i am used to. the square just means “a input”

1 Like


1 Like

Dont know what that means! But PSA seems like a better fit!