Repeater and lifecycle glitch [NOT A BUG, game start only applies for the game host]

So I am made a forever loop that starts when a life cycle on when game starts, but it starts the loop for me but not for my test account. Why?

That’s because the Lifecycle “Game Start” event only applies for the game host because the game host triggered the event, connect the lifecycle to a relay (all players) and the relay to whatever device/s you’re using for the loop.

Also, welcome to the community

It appears to be you’re on a mobile device, gimkit (creative) is not that compatible with mobile devices so I suggest you check this guide out.


Quick Summary:

Anything connected FROM a Lifecycle is only triggered for the Game Host because the Game Host triggered that event.
Connect the Lifecycle to a Relay (All Players)

(Lifecycle) Event Occurs —> (Relay) Trigger Relay

Then, connect the Relay to start/(or if you’re using a trigger, trigger)

Extra tips for mobile

Trying to select a device but it keeps popping up a device your finger wasn’t on?

Select the device and go to the Layers tab.

When you select a device/(s), those devices are the only thing that show up in the layers tab until you select on a blank space.
This also works with deleting/erasing devices/props.

If that still doesn’t work, start and end the game.
I know it sounds stupid but it works. (for me)

If that STILL doesn’t work, refresh and reopen the game.

Okay, this is kinda connected to the previous tip.
If you select a device/prop and try to erase it but it shows a completely different one (if you have already done the select thing in the previous tip), switch the erasing type to terrain and back to props.


Welcome to the forum! Hope you enjoy your time here!


Thank you, by the way I’m in bed and using my iPad with a keyboard. My pc is off.


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.