Post is not showing up

Even though I published my game it isn’t showing up at all I looked at recently published and then I tried to search for it. Even my friends tried but they couldn’t find it. Does anyone know why that is?

Uh… you need to search the title and/or the description. Mark a solution if this answers your question!

I tried doing both and neither worked.

@WolfTechnology Made a guild about this:

Maybe put a unique series of numbers or letters in your game’s description or title that can make searching up the game easier

same with me. I tried publishing my map, and then I tried to see it, but it never showed up! Idk why this happened, I tried refreshing, but I just think it has to to with everyone making a whole lot of maps and it gets bumped out.

Josh improved the discovery search, unless you didn’t publish it then you should be able to find it.

Also, maybe it has something to do with the name:
if the name of your game is very common: don’t look down, battle royal, get a snack at 3. A.M. etc. then it is hard to find.

The only problem is that if the description has numbers you won’t find it :cry: