Why are these cosmetics not showing up in the shop?

1 Like

An error with the image API is most likely occuring

Recent bug on this subject:

it might be a bug! I seen so many of this bug posts but its fine!

just a glitch or a bug, it will be fixed eventually.

in the meantime have you tried refreshing?

refreshing wont really work, i tried that many times earlier.

Report the bug to hello@gimkit.com
Pinging the following about the issue as they have it as well:

Screenshot 2024-03-15 12.17.34 PM
It is doing it to me too still… I believe it is just bad internet.

wait this isn’t bad internet It’s also happening to me… wait remember the detective baka lost his glasses it most likely means there updating the gims right

not bad internet, bc its happening with everyone else.

Okay. Then… must be somethin else.

This has just started happening to me today.

it could be the beta being added

1 Like

This shouldn’t be a issue, its probably just because the gimkit team is tinkering around.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.