Variables aren't working here

So, I’m making typewriter text. (again.)

When I do this:

It doesn’t work.

When I do this:

It works.

Why didn’t the variables not work.
I need the solution.

Sorry, I don’t understand could you explain more clearly?

If I set the variable to code, and place the variable there, it doesn’t work.
If I just put the code there normaly, it 67% works.

idk maybe you want to connect the code to the main block?

Reload? Have you tried with multiple things of code?

here, Clic Clac says it is based on which is made first, and in you want the one made last to go first you must connect pust the “set variable” before the “If do” or just before the “do”

That still doesn’t really work.

I am not sure, but I think maybe variables are supposed to be numbers not text, but tell me if I’m wrong

1 Like

oops I’m wrong, variables can be text, lemme try some more stuff and I’ll get back to you

how bout trying to put them ALL in the “else” chunk in this order

When I said block, I meant the entire unit that gets created when you make a new block in the blocks tab. It might not work due to variables resetting when the block code is rerun. Are there any concatenation properties in the variable?

1 Like


Hey. There is some unknown connection between the order that separate blocks were made and when they run, so you weren’t 100% wrong!

Funny thing, even not connected
Screen Shot 2024-04-19 at 10.05.10 AM
this works

Screen Shot 2024-04-19 at 10.05.52 AM
this doesn’t

I think gimkit reads code from top to bottom even if they are not connected

1 Like

wait what are you trying to do with the blocks and variables?

gimmaster1234 wants to change text in a popup while I was just experimenting

I’m going to test that.

If this doesn’t work, I don’t need it. I would rather have a comma have a 1 second pause, though.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.