Sentries not spawning on game start

When I place down a sentry and start the game, they won’t spawn in.

Many bugs are occurring right now in 2d modes, so this could be correlated to that. The devs are working to fix this right now, as said in the most recent news post.
However, have you tried reloading the game/page? Maybe that’ll fix it.


Yea its been happening like 2 weeks ago about.

Oh, two weeks? That’s absurd… Try deleting the sentries and replacing them…?

Maybe try deleting the map, then making a new one?

uhh I’ve did a lot on it and don’t feel like doing that.

Maybe something in here will help you.

I tried it. Still :frowning:

You must’ve tried many things, considering it’s been going on for two weeks. There’s no random channel disabling them that was activated someway somehow, right?

I haven’t checked yet.

Oh there could be, and that could be tripping up the sentries spawn code.

I would, best lead you’ve got right now…

Ight I’m going to check.

Is the inventory lots 0?

If it is, set the inventory slots 1, 2, etc. and the sentries will spawn.

1 Like

Please tell me, how are the inventory slots related to sentries spawning?

Sentries are sometimes used for you to attack them.

Huh? yea their 0. I have no channels connected to it @TerrariaBoi

Try what FersionSpeedy said then. Turn the inventory slots to one or two.

ok Ill try and do that.