Item granter not working

I’ve tried deleting it and replacing it and changing which device it comes from.

try refreshing the page?

Welcome to the forums, @RandomName!

hes not that new

I tried refreshing it. It still won’t grant the item

are you using wires or channels?

I am using wires. I’ve tried it connected to a questioner and connected to a zone.

@Blackhole927 can you help him?

What should happen with the item granter?

Make sure the receiving and broadcasting channels aren’t mixed up. This happened to me once, and I was SO mad at myself.

1 Like

It should give the player a gold key when they answer a question

Can you show a few snips?

I don’t have a lot of devices and I’m using wires so IDK what’s wrong

Then the wire should be (question answered correctly → grant item).

Yes. That should be right.

It’s set to that but It won’t work I’ve also tried making it give the item when a player enters a zone and that doesn’t work either

Can you use snip and sketch to show us all the settings?

Idk how to do that but I can send a screenshot

Does your kit have correct answers? Are you accidentally using an item spawner?