(IK THIS HAS BEEN POSTED) How To Make An Overlay Only Visible to One Team?

I know this has already been posted, I looked so please don’t say anything about that! Even when I looked it didn’t help!

Anyways this is what I put in the scope

And yes I made it not visible on game start
Here is my relay:

And this is the wire:

Someone tell me what i’m doing wrong or help me please!

I don’t think you need a relay. Also, I don’t think the content scope should be team. Try my first suggestion, first.

1 Like

I had it not on team but I changed it bc it didn’t work, but would I need a lifecycle?

1 Like

No, just make the overlay active on game start.

But how would I make it so that only one specific team (7) can see it?

There is no option in the scope

that’s what visibility does.
Wait, check your map settings. How many teams are there?

I put it to free for all

Well, that’s an issue. FFA doesn’t have teams.

I did and there is nothing

Lifecycle → Relay (set team u want) → Overlay
Make sure it’s not FFA, it’s teams and there are at least 7 teams.

1 Like

I know I just did that

Wait do I make it visible on game start?

It didn’t work when i made it not visible on game start

Okay, so the way teams work is, if you are set to FFA, everyone is on their own team, from up to 60 teams. Your current design seems like it will only make it visible to the person on team 2, on their own team. Are you using pseudo teaming to divide your team into two? Also, it could just be a bug, as I do vaguely remember encountering something like this once or twice before.


No, I didn’t do that and I did the exact opposite of what you said but I just got an idea that just might work!

Nothing seems to be working!

It does, but everyone is on a different team.

1 Like

I don’t think it needs to be team because your already sending the overlay to the whole team.

1 Like

Set visibility scope to player:

1 Like

Same with content scope