Help with red shells

So, I was updating GK8, and one of the big things that I was trying to do was make the red shells act like actual red shells. The way the system works is like so: A person walks into an item box. The game then checks if they have any items. If not, the “Get Item” game overlay pops up. This all works fine. It then checks your racing rank (your position in the race, it also works) and gives you an item out of the corresponding loot table. For this problem, the person is in 2nd, and the probability of getting a red shell is 100% for testing purposes. The game then checks if the item you have is a green shell. It isn’t, so the “Use Item” game overlay is shown. The game then checks for every other item that you could have, so each one can give a different effect. This works, so I’ll gloss over it. It then checks for a red shell. The check passes, so it runs the red shell device system. It first sets a property RedRacingRank to the player who activated the item box’s racing rank, clears the item from the players inventory, then broadcasts to a relay (all) → trigger. The trigger checks if the any players racing rank is equal to the reference rank -1. If true, it broadcasts on a channel that activates the red shell popup. However, it never actually activates. If anyone can provide any help, it would be appreciated! Thanks, and have a nice night!

1 Like

I’m not suit for this type of stuff, but maybe make sure it actually activates, and you could recheck over stuff… I’ve found many bugs by rechecking over my stuff.

small rant

I wish gimkit added it so you know what activated what and what sent out what channels, like it could show in the games activity feed or some code log to tell you
it could help so much

Can you take a screenshot of the broadcast mechanism in blocks

1 Like

It sounds like you’re having trouble getting the red shell device system to work properly in your game. Have you checked to make sure that all of the necessary properties and triggers are set up correctly? It’s possible that there is a small error in the coding that is preventing the red shell popup from activating.

One thing you could try is testing the system with a different type of shell, like a green shell, to see if it is working properly with other items. If it is, then the issue may be specific to the red shell.

Another thing to consider is whether there are any external factors that could be affecting the system, such as network connectivity issues or compatibility problems with other software. It may be worth checking for any updates or patches that could help resolve these issues.

Overall, it’s hard to say exactly what the problem is without more information, but hopefully these suggestions will help you get closer to a solution. Good luck!

1 Like

Make lots of notifications or an overlay that shows what the properties or channel broadcasts are.

I’m almost 100% sure that every part of the system works perfectly, it’s just the part at the end. Thanks for thinking about it, though!

1 Like

Have you tried putting all the channel broadcasts in an overlay so you can see if the channels actually fire?

No, not yet. However, the way the system is set up, every other wire has to fire for the red shell check to work, and the rest of the system works fine.

Can you show a screenshot?

One second.


The relay at the bottom right is the one for the red shell, right?

1 Like

Yep! I got it work with a little help from a irl friend who’s good at coding, so I’ll mark your post as a solution. It was the closest to what worked!

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.