Glitched Gim [Bug-issue]

waaaaaaaaaaaaaaaaaaaaaaaa Fix it

please don’t make more of these posts

this is a glitch that has been happening to multiple people,

@Gimkitsuggestor , please mark a solution as there are 50 of the same topic

change your gim and your should be fine

look at this guide above to know what to do

1 Like

This is a known bug, change your gim most still work. Please mark a solution.

1 Like

Just change your Gim. The default skin worked for me. Please mark a solution.

1 Like

@Gimkitsuggestor please mark a solution so we can move on

would clock o matic work?

im not sure, its different for every person…

no, clock o matic wont work because @cheesebox already tried it, and it glitched.

I think it’s any gim with a custom animation i.e. moving parts besides the base

I tried Zenith and it was completely fine. How does this happen?

Ozi is glitchy too My friend tried and He saw nothing wrong but i do
Screenshot 2023-11-29 10.42.58 AM

but look at this monstrosity!!!
Screenshot 2023-11-29 10.43.56 AM

but such complicated skins like this are fine
Screenshot 2023-11-29 10.45.04 AM

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.