Barrier blocking Sentry bug

I am making peaceful sentries (normal npcs) and I currently have 2 of them. By putting barriers on them they shouldn’t be able to use their gadgets. 1 of them works but the other one doesnt and I did the same thing with both. i’m not sure if this is a bug exactly because it could be a layering issue. Help would… help.Thx in advance!

Maybe try reloading
does the barrier have collision?

1 Like

Is this top-down or platformer?

JKHACKER: Yes collision is on.
harharhar: this is top-down.

Or make it the same team as the player
But barrier will help more

Try increasing the size of the barrier. Maybe that will help?

This is a multi-team game.

Already tried that. It is larger than the sentry but still doesnt work.

Maybe try increasing it more???

There is a small zone around the sentry (as I said it is an npc) and if I increased it more than the zone would not work. Sorry if I am complicating things.

Np. I’m honestly not sure what to suggest. Maybe delete the sentry and the barrier and try again?

1 Like

The only thing I can think to do is to place the barrier on the Above layer
Delete the sentry and replace it

I could try that… but then all the wires… uuuuuhhhh this is so annoying

I will try above layer because as stated above this could be a layering issue

1 Like

Sadly, it didnt work. :frowning:


Sorry I couldn’t be more help :confused:


I think you just might delete the sentry and replace it :neutral_face:

still didn’t work :((((

I also tried replacing the barrier. didnt work. is the detective baka sentry broken?

Yea I don’t know, email gimkit