Unlock Doors Not Working

Hello, everyone. I have a problem. So, a couple of weeks ago I learned how to unlock doors using items. It has worked on the first door, but then I added multiple other doors to be unlocked along the way during my game. In order to unlock these doors, I’m using blue keys, which can be acquired when knocking out sentries.

I used the same devices and options for all of the doors, but changed the items required to open the different doors. For example, here’s the one where you needed four blue keys to open the door. But when I attempt to open the door, it doesn’t unlock and it takes the items away.

So first, here are the devices I used for the unlocking. An item granter, button, checker, and popup. Here are the steps: First, I placed this barrier down, which would be the door.


Then, I added a button that would be in front of the barrier. This is how you unlock the door. I made it invisible so you couldn’t see it.

Then I added an item granter that would take away the blue keys once you tried to unlock the door. I used the channel "unlock door" if you wanted to unlock the door.

Next I used a checker. This would be the device that makes sure the person trying to unlock the door would have the required item. If the check passed, the door would be unlocked and the barrier would be gone.

Then if the check failed, (if you didn’t have enough blue keys) it would send this popup. (I didn’t add anything to the popup, though.

Finally, I added a wire from the button to the checker.

It doesn’t work.
And here’s the video. It explains the overall conclusion.

Use a vending machine instead of this system. It is less likely to fail.

Ok you first place a barrier and then place a button and vending machine. set the vending machine to the nember of key cards you wish it to take and make sure it gives nothing back. Make it invisable in game. Place the vending machine in fron of the barrier at the side you wish and add a button to the left of right front side of the barrier. wire the button to the vending machine. Wire should be “When pressed-activate vending machine”. Next wire the vending machine to the barrier. Wire hould be “when item purchased-deactivate barrier”. Make sure the vending machine can be purchased only once.

Let me know if this helps @California_Love.

You need to be more specific and explain the whole system that is needed.

I can do that. OK. Give me a minute.

It’s just having a vending machine. I’m not explaining that.

Then it will not be helpful. The best way to help is to explain, trust me.

Ok, let me know if that does or doesn’t work.

Do I need TWO buttons or just one? (I have tried it)
Sorry, I was busy for a while.

Just one

It doesn’t seem to be working. Is this what it’s supposed to look like?
This for the vending machine.


Screenshot 2023-12-01 11.42.32 AM
This for the button.

Here are the wires.


Here’s the overall look. Is this right, or are my options wrong in some places?*
Screenshot 2023-12-01 11.41.25 AM

*By the way, thanks for coming back to help. I appreciate it.

Give me one moment to get screenshots on my end.

Ok so no button needed, use a vending machine and barrier. Here are the settings.



3 Likes

Connect a vending machine, make it invisible, and connect it with barrier with a wire to need an item to unlock the barrier @California_Love !

1 Like

@jch10 the images above depict that, aswell as the rest of some post.

1 Like

Did you make the barrier disappear when it transmitted unlockdoor?

2 Likes

Oof. They just scammed you!

1 Like

Yes I did, look at it yourself.

1 Like

What do you mean?

1 Like

They summarized what you said and copied you.