Two bugs I found

Bug one (Most important one)

I made a setup to randomize the the item you need and the amount of it you need. This is the code:


The “menu item” works fine. But the amount doesn’t work. It always says “0” when I run it. This is the game overlay:

This is it in game:
Screenshot 2024-04-10 6.33.27 PM

The second bug (May have been reported before.

Look:


Screenshot 2024-04-10 6.35.15 PM
Screenshot 2024-04-10 6.35.30 PM
WHY

I tried reloading.

1 Like

The second is probably because of the way the blaster moves, because it needs to be infront of a prop to be seen. For example, if you moved your blaster over a stone barrier, it would be in front of it.

But why does it work sometimes and doesn’t other times?

Thats probably the game having weird logic, I think its supposed to be under a prop, but sometimes if the sentry moves a blaster it gets messed up

Is there a fix?

Probably not, because like I said its built into the coding with some layering “bugs”, so there is probably a way to temporarily fix it. Nothing would be permanent though.

Okay, do you have any idea whats going on with the first question?

um ._. no sorry i’m not really a coding person

1 Like

what you’re doing is setting the “amount” variable to the “amount of menu item” property when you probably need to set the “amount of menu item” property to the “amount” variable

1 Like

Oh, I didn’t notice that… Let me test it.

Edit: @samalomlom, how would I do that?

wait lemme get a screen shot


put the channel so you know where it goses

1 Like

I just put this:
Screenshot 2024-04-10 7.12.11 PM
(Forgot about the set property block…)
It works, but it’s only giving me sandwitches. (I’m going to test this again, so see if it’s just luck.)

Edit: it’s just luck.

2 Likes

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.