Things Stop Working?

So, I made a barrier that deactivates when you get a blue key. Worked great. Then I added a new barrier that deactivates with a blue key…same exact way. Now the first barrier won’t deactivate and the new doesn’t work either??? This is just one example. I get one thing working, add new things unrelated to my other things and stuff just stops working. When I delete newly add things, it seems to go back to working. What am I doing wrong here??? Thank you in advanced!

1 Like

Could you please provide a screenshot? I will be able to help you better if I see your devices and your device settings. Thanks


This is one of my barriers. After some further testing, its not so much that it stops working its more that it doesn’t work consistently. For example, when I enter the zone, it checks for green key. Then the button activates. The button deactivates the barrier. I have to run in and out of the zone several times for it to work.

Another example is I have a gold key barrier set up the same way. The button activates instantly but then I had to press the button about 8 times to get the barrier to go down. Any help is appreciated. Thank you!

I would like to request what the repeater and zone does?

This may be a bug…

Try using lasers with 0 damage, so you can detect when the player was hit by a laser.

The Zone, when activated, activates the button. Not sure what the repeater does. This is how I was told to set up a door to open with a key. I have zero coding skills and I think the person helping me thought this might be the easiest way for me to get it to work.

Why does it transmit to itself?

I just built the full system and it works for me it appears that the best way to get it to work is this screenshot:

There is no need for anything else.

Is this still not working?

I don’t believe so as I just build it successfully in the image you see above where it was working.

Ok so recently i had a glitch in my astroids task where the zones stopping these sentrys just straight up stopped working, they worked previously and there code was fine. (i was able to fix the issue but not the bug) Basically where im going with this is that theres a bug in gimkit affecting certain players zones, triggers, and like your case possibly barriers. Theres been another post similar to thos talking about how this is related to the new update coming out (dont look down) even though its not out but on the homescreen it still affecting us. I suggest either finding a diffrent way to do what your doing or delete and replace the buggy items.
Hope this helps!

Happy gimkiting
~ImaDinosaur

Btw i have yet to check if it affects evrey zone/other buggy device in the game or just a few.

I just checked and it only applied to the origanal zones for me that were bugged.
In conclusion, just a bunch of very weird shenanigans. I also no longer trust what settings of devices say.

Might be a bug or something I have no idea.

Welcome to the forum, @AquaTanuki!!!

1 Like

@bcoughlin what is your setting in the checker? Make sure it is “larger then 0”.

no he wants the button to activate only if you have keycards

1 Like

what does the lifecycle do?

1 Like

Ok I am editing the system to be catered for histhe need for the button only to activate if you have keycards.

The repeater should be wired to the checker.

1 Like