Item Granter Malfunction

How come I wired a questioner to a raspberry item granter and told it that whenever you answer a question right, you get 1 raspberry. However, I tested it, and I answered a question right. It did not give me a raspberry. Do you guys know how to fix it?

2 Likes

Could you send a screenshot? Also welcome to the forum!

1 Like

Welcome to the community! can you tell me the wire or channels you used to make the function?

1 Like

Welcome to the forum, @PhoenixFire

Welcome to the forums, @PhoenixFire !
Make sure to check out new-user-must-read and forum-tips

Welcome to the forum, @PhoenixFire! I’m not sure how to fix it, but someone else might know.

@Billybanana @WolfTechnology @The_7th_Dragon @Cyan_Tiger_Reigns @WhereIsMyHat Here:

What are the item granter and questioner settings?

Have you tried refreshing it?

You’re wires seem right… maybe just a glitch? Can u send a screenshot of settings?

Maybe try using channels?

Hmm. Yeah might be a glitch, @PhoenixFire

Yeah try using channels, I guarantee it’ll work if you do that correctly.

in having the same problem, any tips?

Do you mean a notification didn’t pop up or it didn’t go into your inventory?

Welcome to the forum!

Welcome to the forums, @amongus !
Make sure to check out new-user-must-read and forum-tips

Welcome to the forum, @amongus!

They do look right, what if you made it over again (Sorry it took me so long to respond, I had lots of work to do)

To reiterate it:

  1. Place down a Questioner
  2. Place down an Item Granter
  3. Set the granting Item a Raspberry and 1 individual given
  4. Wire the Questioner TO the Item Granter
  5. Select that if you answer the question correctly, grant item.
  6. If that doesn’t work, check the settings for the Map.
1 Like