Bug with copying and wires

So, I’m working on a game where you need to clean up trash. Basically the wires are:

When button pressed —> hide prop

and

When prop hidden —> deactivate button.

For some reason, when I copy the trash + button and hook up the wires, it all goes to the first one. It’s hard to explain.

I don’t think I can fix this without using channels (ugh), but just wanting to put it out there so maybe someone can tell Gimkit. I can’t because school blocks any outside emails from coming in or out (double ugh).

Button Pressed → Hide Prop
Button Pressed —> Wire repeater
Wire repeated —> Deactivate Button

I tried that, still just going to the first one only. I have to make them all by hand now instead of copying :frowning:

So its not letting you connect it to the first one?

No, its like when I connect the wire to the ones I copied, the wire just goes to the first, not the copy.

ah. Have you tried getting a fresh one from the props section where the devices, terrain, and wires are?

Yes, it seems to work that way. It’s more of an annoying bug than a really bad bug.

Yeah, that’s what it sounds like.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.